Welcome, Guest

TOPIC: the game run slow on great computer...

the game run slow on great computer... 2 years 9 months ago #2624

i, i need i hint, the game is running slow on my computer. I can't manage the game to run at full speed it slow and laggy.

Gtx1070
i5 4690k
16gb ddr3
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2641

Quick read concerning the GPU of yours, some people have experienced low FPS with it due to faulty drivers. Wouldn't probably be a bad idea to try clean installing your Nvidia's drivers or at least updating them.

What OS do you have ?
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2658

Hi,

Thanks for your reply i really want to play this game :) Sadly i tried to clean uninstall then reinstall my drivers (gtx 1070) but without luck. I was able to get 60 fps on windows mode by changing from full screen to windows a couple of time but after 5 sec of seconds it revert back to 42-43fps making the game play laggy and not how it is supposed to be. i can upload you a video to show you if you want or anything that could help you fix my problem. I am on windows 10 pro x64

Thanks for you help! i really appreciate
Last Edit: 2 years 9 months ago by Rivest.
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2667

Please try running the game on Windows 7 compatibility mode. I am not sure if it helps any or not but I know it helps with some other issues in the game.
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2674

  • DDRKhat
  • DDRKhat's Avatar
  • OFFLINE
  • Megaman 2.5D Team
  • Posts: 91
Also out of curiousity. Which install are you using? The installer or without installer?
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2689

I tries both installer and without installer, also tried windows 7 compatibily mode! :( Im playing it on my laptop for now and it works perfectly fine. Im wondering if my gtx 1070 is too fast for that haha

edit : just tried disabling msi afterburner and riva runer at windows statup and nope still 43 fps and lag.
Last Edit: 2 years 9 months ago by Rivest.
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2691

I seem to be having the same problem with slowdown, my specs are:

Gtx 1060
i7 6700
32 gig ram
Win 10

I'm getting 48-49 fps, with an occasional jump to 60 on both installed and standalone versions of 1.0 and 1.0.1. Drivers are up to date, this laptop is only 2 months old. Game is frustrating with this slowdown. :(
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2692

I seem to be having the same issue with slowdown. My specs are:

GTX1060
i7 6700
32gb ddr3
Win 10 Home

Stuck at 48-49 fps according to fraps, on both installed and standalone versions of 1.0 and 1.0.1. I've seen occasional spikes to 60fps but usually its slow. I'm up to date on graphics drivers too, this laptop is only 2 months old. Game is almost unplayable with this slowdown. :(
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2755

This may be helpful to some of you experiencing slowdown. A player managed to solve his slowdown this way:

"I found a solution. Must never set the CPU priority to High on the Task Manager (Yes, some things are unstable with the High Priority)."
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2833

Priority is set to normal i double checked. I tried to set it on high then revert back to normal because this dis not work. I am pretty sure this has something to do with the nvidia drivers (i have the lastest version...)
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2843

Note: Do not do this if you don't know what are you doing. But, you could run DDU in order to uninstall your drivers completely and install fresh ones. Here is guidance for that : docs.google.com/document/d/1xRRx_3r8GgCp...DYKWvjsW0rLcYQ0/edit

Unfortunately from what I have heard, a lot of people have had issues with GTX 1060 stuttering, lagging, and such as that. There have been various ways some have fixed it, one being DDU and installing fresh drivers, others have had success tinkering with the Nvidia's Control Panel, such as setting Maximum Pre-rendered Frames to 1..

I am sorry to hear of the issue still persisting.
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2861

Ok, so i tried DDU clean uninstall driver, reinstalled. Same problem...Then i realised i play on a tv this is a desktop pluged on a toshiba 1080p tv. So i pluged a 20 in monitor via dvi and was really hoping this was the issue but no...I am really out of solutions now :( it must be related to nvidia drivers somehow i could try older version of nvidia drivers? What do you think?

edit : i also tried predenred frames too and nope still the same low fps and lag
Last Edit: 2 years 9 months ago by Rivest.
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2869

Does your FPS vary at all if you are actually ingame, in the menu, etc ? Or is it the same result everywhere ?

I do find it interesting that switching window modes makes it first run fine for awhile, then drops down to 40 or so.. I find it interesting because when the window is unfocused, I usually get exactly that kind of FPS. I wonder could it be that something is making the window become unfocused, like, something is taking priority over the gameplay window..

I'm running a bit low on ideas but this unfocusing thing has been in my mind a little as of late due to some other things that have been going on in the game so I was just wondering about that. Please try to close down any background programs you might have on at least. I am unsure if it will help any but it's worth a try at this point.
Last Edit: 2 years 9 months ago by RedFoxxie.
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2877

You could try also changing the refrest rate of your monitor and disabling or enabling vsync, just a thought.
The administrator has disabled public write access.

the game run slow on great computer... 2 years 9 months ago #2892

I tried to change monitor for vga monitor insted of tv and also tried my onboard intel hd 4600 and same problem so it really must be a application or something like that but i disabled every app on startup but that did not help i need to check maybe the services at this point. but it has to be realated to something that is on windows startup. That wierd its the only game that gives me this problem, im playing emulators, new games, old games but megaman 2.5d is the only one giving me problems.
The administrator has disabled public write access.